<div dir="ltr"><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div class="gmail_extra">Richard Palethorpe <span dir="ltr"><<a target="_blank" href="mailto:rpalethorpe@suse.de">rpalethorpe@suse.de</a>></span> wrote:<br><div class="gmail_quote"><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><div><div class="gmail-m_7474187562108432668h5"><br>
> #define MAX_DISPLAY 40<br>
> +#define MICROSECOND 1<br>
<br>
</div></div>Not necessary.<br></blockquote><div><div class="gmail_default" style="font-family:monospace,monospace;display:inline"><br></div><div class="gmail_default" style="font-family:monospace,monospace;display:inline">Ok.<br></div> <span></span><br><span></span></div><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><span>
><br>
> for (i = 0; i < worker_count; i++) {<br>
> - stop_attempts = 0xffff;<br>
> if (workers[i].q) {<br>
<br>
</span>Maybe change this to:<br>
if (!workers[i].q)<br>
continue;<br>
<br>
To avoid a level of indentation.<br></blockquote><div><br><div class="gmail_default" style="font-family:monospace,monospace;display:inline">Sounds good.<br></div><br></div><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote"><div><div class="gmail-m_7474187562108432668h5">
> + tst_brk(TBROK,<br>
> + "Attempts %d times but still failed to push %s",<br>
</div></div> ^ Attempted<br></blockquote><div><br><div class="gmail_default" style="font-family:monospace,monospace;display:inline">Good catch.<br></div> </div><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote">
<br>
> + push_attempts, path);<br>
> }<br>
> }<br>
> }<br>
<br>
Maybe you could put the "if (delaly < SECOND) ..." into a function?<br></blockquote><div><br><div class="gmail_default" style="font-family:monospace,monospace">Firstly, I was thinking to take use of my new macros, but<br></div><div class="gmail_default" style="font-family:monospace,monospace">consider that have not been reviewed. So I tend to keep<br></div><div class="gmail_default" style="font-family:monospace,monospace">it as original, then replace them entirely after ltp gets<br>a generic loop functionality in library.</div><br> </div><blockquote style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex" class="gmail_quote">
<br>
Otherwise this looks good to me. There are some other things I want to<br>
change on this test, but we can leave those for another patch.<br></blockquote><div><br><div class="gmail_default" style="font-family:monospace,monospace;display:inline">Thanks, Patch v3 is coming...<br></div><br></div></div><br>-- <br><div class="gmail-m_7474187562108432668gmail_signature">Li Wang<br><a target="_blank" href="mailto:liwang@redhat.com">liwang@redhat.com</a></div>
</div></div>