[bglug] proftpd 1.3.0 + mysql

Alexandro Ghettini joeriker@cyber-city.us
Mer 6 Dic 2006 18:18:27 CET


Ciao a tutti
sto giocando con l'ultima rilascio di proftpd come da oggetto, ma invece di fare la tipica autenticazione da /etc/passwd ho implementato il proftpd-mysql, tutto funziona perfettamente ... troppo....
difatti mi autentica gli utenti nel dbms ma anche gli utenti del file /etc/passwd, controllando howto, manuali e forum vari, impostando

RootLogin off

taglio un bel po di problemi di security, impostando anche 

PersistentPasswd                off

in teoria dovrebbe ignorare gli utenti di /etc/passwd e eseguire solo l'autenticazione del

SQLBackend mysql

in pratica gli utenti in /etc/passwd continuano bellamente ad essere autenticati via FTP (tranne root .....almeno quello -.- )

Qualcuno sa come posso bloccare l'autenticazione sul file /etc/passwd (non "chmod 000 /etc/passwd" ne "rm /etc/passwd -Rf :-P )



Poi, secondo problema che non capisco,

ho una vecchia macchina con installato ProFTPD Version 1.2.10, fino a qualche tempo fa, dall'invio comando "ftp xxx.xxx.xxx.xxx" all'apertura della connessione (e richiesta nome utente e pwd) impiegava pochi decimi di secondo, di punto in bianco ha preso a restare appeso un buon 10 secondi prima di richiedere uid e pwd, poi una volta autenticato put, get dele, ls ecc.. sono fulmini ad essere eseguiti, commento personale.... "bho sta macchina ha qualche annetto, si sarÓ rincoglionita, sarÓ stato fatto qualcosa di sbagliato"
Questa macchina nuova, appena formattata e setuppata, fresca fresca di "apt-get install proftpd" fa lo stesso scherzo....  "ftp xxx.xxx.xxx.xxx"+ invio.... ed eccola appesa 10 secondi prima della richiesta di uid/pwd (usando un client tipo cuteftp/wsftp, guardando lo stato sembrerebbe restare appesa alla richiesta del welcome.msg), ah ... mentre la macchina vecchia Ŕ pubblica su web questa macchina nuova di prova Ŕ in rete locale 10Mbit e richiamata via ip (giusto per escludere rallentamenti di traffico o risoluzione nomi).

qualche idea se sia normale questo comportamento o se devo abbassare qualche idle time o timeout?

Grazie
Alex




Maggiori informazioni sulla lista bglug