[FoLUG]Sembrava facile....

Carnesecchi Dario folug@lists.linux.it
Thu, 24 Jan 2002 02:16:41 +0100


Mi rivolgo ai debianisti:

ho avuto un problema nella compilazione del kernel, il solito vecchio 
problema di qualche kernel della serie 2.4.* che dava come errore il seguente:

drivers/usb/usbdrv.o(.text.lock+0x7c1): undefined reference to `local symbols 
in discarded section .text.exit'
drivers/usb/usbdrv.o(.text.lock+0x7cb): undefined reference to `local symbols 
in discarded section .text.exit'
make[1]: *** [vmlinux] Error 1
make[1]: Leaving directory `/usr/src/linux'
make: *** [stamp-build] Error 2

In pi di un sito ho trovato segnalazioni di users che "downgradando" le 
binutils da 2.11.92.0.12 a 2.11.92.0.10 hanno risolto il problema.
Piccola parentesi: ho compilato lo stesso kernel con successo con la versione 
+ nuova delle binutils su un vecchio Pentium 120, non mi spiego, a parte la 
differenza di hardware come abbia potuto funzionare...

Cmq, il mio problema  questo:

come downgradare un package .deb senza far succedere un kasino con le 
versioni, le dipendenze e tutto il resto? Ma soprattutto, quali source devo 
mettere nel file di conf. dell'apt? Giuro che ormai ho cercato in ogni dove 
ma mi sta venendo un esaurimento nervoso, xch non riesco a combinare 
assolutamente niente ! :-(
Grazie mille boyz

The Crow