[gl-como] compilazione a 64bit

Pietro "m0nt0" Montorfano monto@gl-como.net
Gio 1 Mar 2007 01:13:22 CET


Genio del Male ha scritto:
> Mi rendo conto ora che state facendo i conti con un versione da cvs... 
> ma vi ricordo che le versioni da cvs non son garantite compilabili, 
> tanto meno garantite stabili.... Ŕ proprio necessario usare la versione 
> cvs!? il motivo per cui nn compila Ŕ proprio questo: o vi fate voi gli 
> scazzi a risolvere i problemi di compilazione, mettendo mano al codice o 
> prendete un'altra versione...
> 
> cmq a giudicare dal log, la directory
> 
> ../xmltok/.libs
> 
> non Ŕ proprio lý dove la vorrebbe...
> 

ehhh gia, peccato che prendendo da sorgente una qualsiasi versione
(provato con cvs e stabile) comunque non compila (e ho bisogno della
1.09 in particolare dato che risolve dei problemi).
Sono arrivato anche piu avanti di li, per proseguire basta andare nella
dir lib/expat/xmltok e dare un make, poi da dentro .libs appena creata
dare "ln -sf ./ .libs" sempre per un errore nel make, la compilazione
farÓ ancora qualche file e poi scasserÓ le balle ancora per un po di
volte con i .libs non trovati perchŔ cerca i file in
"qualcosa/.libs/.libs/file", per ovviare basta spostarsi in
"qualcosa/.libs" e dare un bel "ln -sf ./ .libs". Dopo circa 3 o 4 di
sti link si incazza riguardo a qualcosa tipo il size_t dell'include di
<string>. Volevo solo sapere comunque se dava solo a me sto problema o meno.

> Ciao.
> 

Ciao!


Maggiori informazioni sulla lista gl-como