[gl-como] Upgrade a ubuntu 12.4, addio WOL

Jio jiojio74@gmail.com
Ven 15 Giu 2012 22:32:57 CEST


Ho uno scrippettino sul dreamplug che di notte sveglia una macchina
ubuntu e sposta un p di file. Sino a un mesetto fa funzionava
correttamente, oggi mi sono accorto (disco pieno) che non funziona
pi. La macchina l'unico cambiamento che credo di aver fatto  quello
di aver aggiornato alla 12:4 la macchina con ubuntu.
Un p di dati che mi lasciano perplesso:
Lo script dovrebbe svegliare la macchina con:
wakeonlan -i 192.168.0.255 14:da:e9:e9:76:92
ma non la sveglia.
Ho provato anche dalla mia Fedora con:
wol 14:da:e9:e9:76:92
e
wol 14:da:e9:e9:76:92 -v -h 192.168.0.255
ma niente.
Sulla macchina con ubuntu ho tolto network-manager e questa  la
configurazione manuale:
#cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 192.168.0.3
        netmask 255.255.255.0
        gateway 192.168.0.2
        up ethtool -s eth0 wol g
e una volta partita la macchina vedo correttamente:
#ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

che dovrebbe essere corretto.
Noto che quando lancio wol non si accende la lucetta della lan sulla
macchina ubuntu cosa che invece succedeva e succede ancora quando la
macchina  in sospensione.
Suggerimenti?

P.S.: ora che ci penso ho aggiunto una schedina spdif, ma  solo
unraiser dalla scheda madre.


Maggiori informazioni sulla lista gl-como