[gpm]Conflict between gpm and acpi?

Nico Schottelius nicos-mutt@pcsystems.de
Sat, 11 May 2002 03:27:47 +0200

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Troy Schultz [Mon, Apr 08, 2002 at 08:03:42AM -0400]:
> [acpi20020225+gpm]
> Here is a summary of what is happening;
> - Start the system normally to init level 5 (X is running), it does not
> matter if I log in and start gnome or KDE, or just stay at X login
> screen
> - change to console mode using <CTRL><ALT><F1>
> - if you change back to X using <CTRL><ALT><F7> then X hangs part way
> through redrawing screen.  There is no mouse or keybaord.
> - X is using over 99% of CPU and the only way I have been able to clean
> things up is to ssh into the notebook and restart the system.
> - I can SysRq-B and reboot, but the ext3 filesystem doesn't like this.

sysrq+s,+u,+b helps a lot...
sounds like acpi or another kernel problem, gpm should not be able to
stop X redrawing.

> Oddly enough if I start another X session on display 1 <CTRL><ALT><F8>
> and us it and never switch to the session on display 0, everything is
> fine.  I can switch between console and display 1 with no problems.

I had this problem someday with my nvidia tnt card, too.
It stopped in newer X versions.

> I have only found this problem with gpm version 1.20.0, this does not
> happen with gpm 1.19.6.  I have also verfied that this same problem
> happens if I configure gpm for a standard ps/2 device and not the synps2
> device I normally use.

exactly the same setup & gpm 1.19.6 works ?

> I have also found the following;
> - start with identical kernel 2.4.17 with no ACPI compiled in and
> everything is fine.
> - start with kernel 2.4.9-21 and acpi 20010615 compiled in and
> everything is fine.

doesn't that sound like a kernel problem ?

> - have tried using X with direct ps/2, not using gpm, and everything is
> fine.

oops. that does not sound like a kernel problem.

> - have tried gpm 1.20.0 with and without Peter's patches and the results
> are the same.
> - have tried gpm 1.20.0 using ps/2 instead of synps2 protocol and
> results are the same.

did you try gpm -D for debugging ?

> - have tried starting to init level 3 and logging in and then using
> startx, but this gives the same problem.

there is no real difference, if you start X or init does.

> I am still doing some tests to determine why this is happening, and will
> probably try a newer ACPI patch to see what happens.

any new information ?



Nico Schottelius

Please send your messages pgp-signed or pgp-encrypted.
If you don't know what pgp is visit www.gnupg.org.
(public pgp key: ftp.schottelius.org/pub/familiy/nico/pgp-key)

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: Weitere Infos: siehe http://www.gnupg.org