[gpm]clone wheel mouse SYM1320 not working with gpm

mlaks mlaks@bellatlantic.net
Thu, 2 Jan 2003 08:49:52 -0500

Dear GPM list,

I am running gpm-1.19.3-21 which comes with  red hat linux 7.3.=20

I have been using a generic clone ps/2 wheel mouse (it is a Solid Year
SYM1320). It works fine as configured as a imps2 under X with my XF86Conf=
file with entry

Section "InputDevice"
        Identifier      "Mouse0"
        # Modified by mouseconfig
        Driver          "mouse"
        Option          "Device"                "/dev/mouse"
        Option          "Protocol"              "IMPS/2"
        Option          "Emulate3Buttons"       "no"
        Option          "ZAxisMapping"          "4 5"

however, it doesnt work at all under gpm, in console mode with no X, with
intermittent flashing on the top line and random copying of stuff to the
command line. I cant use gpm to do simple cut and paste with 3rd button, =
there is no function as wheel mouse under emacs :(.

If, however,  I set up as a generic ps/2 3 button mouse using redhat=20
mouseconfig, then
now it works fine under gpm, console mode, and will copy using wheel as t=
button etc, but then it won't  work under X - wheel no longer works under=
- even though the only change I can now see in the section XF86Config-4 f=
above is substituting "PS/2" for "IMPS/2" - the ZAxis stuff is still ther=

So if I manually change the PS/2 to IMPS/2 and stop and restart X, then n=
the X is fine - wheel and third button, but now if i do ctl-alt F2 and lo=
at a console - now the gpm stopped working. ?why :(.

Any idea what I can do to have X version and console version of wheel mou=
working both? I tried all the setings in gpm -t after killing with gpm -k=
=2E no
go. As long as the  XF86Config-4 says IMPS/2, the gpm refuses to do its
mousey thing. :(.

Thank you very much :)