[gpm]gpm causing keyboard hangs?

John Galbrit jgalbrit@yahoo.co.uk
Mon, 13 Jan 2003 16:38:07 +0000 (GMT)

MB: Asus A7m266

Mouses tried (all PS/2): Logitech cordless wheel mouse (generic)
    Microsoft Intellimouse 1.2A
    Various Microsoft Wheel Mice

Keyboards tried: Logitech cordless (combo'ed w/Log. mouse)
    NEC 104 key
    Generic 104 key

Binary - GPM-1.19.3 Redhat version
Built from source: GPM-1.19.6,1.20.rc1, 1.20.1

Binary - Xfree (whatever Redhat 8.0 bundles)
Built from source: xfree 4.2.0, xfree 4.2.1

Protocols used: imps2, exps2, ps2 (plain ps2 doesn't work at all)

OS: RH 7.2, RH 8.0, LinuxFromScratch

Kernels: RH 2.4.8-?, RH 2.4.18-?, 2.4.18, 2.4.19, 2.4.20

Error message: keyboard: Timeout - AT keyboard not present?(f4)

Problems: When booting (into console) gpm works fine (imps, exps2
only). If I startx, mouse works fine (IMPS/2 only). When I exit X, the
keyboard usually (90%) goes haywire with above error message. Any key
combinations I tried give unrecognized scancodes. If I move the mouse
even the slightest bit, or hit a mouse button, then the keyboard and
mouse totally freezes. I can't currently ssh to see what's up and the X
log has been unfruitful. Also, if I don't start X, everything is fine
unless I stop, then restart gpm. Same thing happens. I'm not running in
repeater mode. Just a simple gpm -m /dev/psaux -t {imps,exps}. I have
tried Mouseman and some other protocols, but they don't work.

Any ideas where to go from here?

John Galbrit

Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts