[gpm]Support for 350WL cradle mouse wireless optical from Trust

Piotr Sawuk a9702387@unet.univie.ac.at
Mon, 26 May 2003 15:21:01 +0000

it's a great mouse, and it kinda works in linux. however there are
still some minor issues which do not seem to be a problem for the
windows-driver (the standard IntelliMouse one):

when I turn off the computer completely (pull the plug for some time
until the led on the cradly goes off), and then I turn it back on,
linux starts (2.4.18 kernel) but gpm (1.20.1rc1) reports "Unknown
mouse type 250", and then falls back to standard ps2. if I move
the mouse after that gpm starts off in the upper right corner
and with faster and more erratic movement applied it starts
selecting and pasting random stuff and finally activates random
commands from the -S option (or discards them as too many buttons
are reported). I haven't tried using the ps2-protocol, but I doubt
it's supposed to work this way. once I started X (4.2.1) it worked
fine, and then back at the console it behaved this way (back then
I didn't try using it before starting X, so it might be the same
problem). I didn't try to reproduce this though. anyway, with all
this strange behaviour in effect I only have to kill gpm (with the
-k option) and restart it (again with exactly the same options as
before: -t imps2 -m /dev/psaux -Rraw -S"") and it works great. a
reset too is capable of resolving the problem. I even tried to
put a "gpm -k" into my startup-files to start gpm a second time.
(with a "sleep 5" in-between, as otherwise it just complains that
another instance is still running and refuses to start, with the
effect that no mouse is available. what I've also seen is some
text aligned in a step-stone pattern saying something about woops
or something when I started mc for the first time after such a
double-execution of gpm without the neccessary sleep inbetween.)
still no success, and both reported the unknown mouse-type,
even when I move the mouse-wheel and mouse during bios-startup.

another thing which bugs me is that I found my mouse to work better
in X when I offer the explorer mouse-type to X (it's a 5-button
mouse and the fourth and fifth button only works with this driver,
although I haven't found a way to test the mouse-wheel). however,
the only time I tried putting this mouse-type into my start-up
files for gpm, it worked in a similar way under X as described
for the console, and of course back at the console it did that
too. however, again, when I killed gpm (it probably had the imps2
driver with the above problem in use before I killed it) and started
it with this exps2 mousetype again it did work great on the console
and in X. I probably should also mention that my mouse didn't work
with previous versions of gpm at all, neither on console nor through
this gpmdata-device in X, I had to kill it after startup in order
to use it in X (that was gpm version 1.17.8 I guess). So many thanks
to whoever fixed this driver...

As I said, it's a 5-button mouse with scroll-wheel (as middle-button),
and according to the package it is Microsoft Mouse, Intelli Mouse and
Win2000 5 button compatible (is the last one the mentioned explorer
mouse-type?), including plug&play (I haven't tried this in gpm though,
nor am I running any PnP-software at startup except for the one driver
required for sound-support which gets loaded after gpm). according to
the manual the homepage is www.trust.com/13091 where registering is
required. I am not using any devfs, but mouse-test still refused to
work (it hung after I had to move the mouse and press a key). In
windowsME I'm using the intelliMouse driver since it offers access
to all 5 buttons in HalfLife (funnily in the first game the
scroll-wheel doesn't work, except in the menu, and in all later
games it works again), unlike the driver on Trust's CD, which only
offers the possibility to assign some key or other function to the
buttons 4 and 5. also I haven't found any info on baud-rate or
resolution or whatever precision-measurment anywhere. but then,
it was a relatively cheap mouse...

oh, and another funny thing is that in X, even though I assigned
the scroll-wheel to the buttons 6 and 7, moving the scroll-wheel
upwards does get reported in my favourite program as button 5
(or was it button 4? I've assigned them both to the same function),
and mouse-wheel down does only have an effect in my old gnome-edit.
when I use the mentioned explorer-driver in X however, the buttons
4 and 5 result in some kind of pgup or pgdown in all gnome-software
while the scroll-wheel does not seem to have any effect at all,
and I can not assign the Btn6 event to anything in my favourite
program as this event-name is unknown. it's quite strange how
GEdit behaves differently when intellimouse-driver is used in X
(it behaves as though the scroll-wheel would be the first mouse
button, in both directions, while some other program behaves as
though wheel-up would be button 4 or 5 and wheel-down wouldn't
even exist), than it behaves when the explorer-mouse-type is
used in X...

I'm willing to help developing and testing a driver for my mouse,
but  don't know much about programming except some Assembler and C.
I don't even know much about the linux-libs dev-tools and kernel,
but I can learn. just tell me what you want me to do.