[ImoLUG] problema apt-get ?

Mario Giammarco mgiammarco@gmail.com
Lun 15 Mar 2010 12:44:53 CET


Non abusare dell'autoremove, in questo caso per esempio ti toglie
ttf-liberation che e' un font utile... magari lo stavi usando, anche se
tecnicamente nessun pacchetto ubuntu lo usa.

Perche' sei rimasto alla 9.04?

per risolvere il problema di quel pacchetto occorre mettere
--force-overwrite nelle opzioni di default. Non ti dico come si fa perche'
e' un'opzione che va prima compresa per bene quindi: documentati :-P

Il giorno 15 marzo 2010 12.38, Oscar Goo <oscar.goo@gmail.com> ha scritto:

> Ciao All...
> vi chiedo una mano essendo un niubbo completo di linux..
>
> su questo portatile ho su ubuntu, versione 9.04
>
> ho qualche problema con l'aggiornamento dei pacchetti, sicuramente per
> causa mia :-)
>
> apt-get autoremove mi genera:
>
> oscar@R61-ubu:~$ sudo apt-get autoremove
> Lettura della lista dei pacchetti in corso... Fatto
> Generazione dell'albero delle dipendenze in corso
> Lettura informazioni sullo stato... Fatto
>  consigliabile eseguire `apt-get -f install' per correggere questi
> problemi.
> I seguenti pacchetti hanno dipendenze non soddisfatte:
>   gnomad2: Dipende: libmtp8 ma non  installato
> E: Dipendenze non trovate. Riprovare usando -f.
> oscar@R61-ubu:~$
>
> apt-get -f install :
>
> oscar@R61-ubu:~$ sudo apt-get -f install
> Lettura della lista dei pacchetti in corso... Fatto
> Generazione dell'albero delle dipendenze in corso
> Lettura informazioni sullo stato... Fatto
> Correzione delle dipendenze in corso... Fatto
> I seguenti pacchetti erano stati automaticamente installati e non sono pi
> richiesti:
>   wine-gecko ttf-liberation libhildon-1-0
> Usare 'apt-get autoremove' per rimuoverli.
> I seguenti pacchetti verranno inoltre installati:
>   libmtp8
> I seguenti pacchetti NUOVI (NEW) saranno installati:
>   libmtp8
> 0 aggiornati, 1 installati, 0 da rimuovere e 34 non aggiornati.
> 1 non completamente installati o rimossi.
>  necessario prendere 118kB di archivi.
> Dopo quest'operazione, verranno occupati 578kB di spazio su disco.
> Continuare [S/n]? S
> Get:1 http://archive.ubuntu.com jaunty/main libmtp8 0.3.0-1ubuntu3 [118kB]
> Scaricato 118kB in 1s (90,2kB/s)
> (Lettura del database ... 198714 file e directory attualmente installati.)
> Spacchetto libmtp8 (da .../libmtp8_0.3.0-1ubuntu3_i386.deb) ...
> dpkg: errore processando
> /var/cache/apt/archives/libmtp8_0.3.0-1ubuntu3_i386.deb (--unpack):
>  tentata sovrascrittura di `/usr/lib/libmtp.so.8', che si trova anche nel
> pacchetto libmtp
> Processing triggers for hal ...
> Regenerating hal fdi cache ...
>  * Restarting Hardware abstraction layer
> hald                                                                [ OK ]
> Sono occorsi degli errori processando:
>  /var/cache/apt/archives/libmtp8_0.3.0-1ubuntu3_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> oscar@R61-ubu:~$
>
> prima di entrambi avevo fatto un apt-get clean
>
>
>
> consigli? sfanculamenti? :-)
>
>
>
> _______________________________________________
> ImoLUG mailing list
> imolug@lists.linux.it
> http://lists.linux.it/listinfo/imolug
> Connettivita' offerta da Waymedia - http://www.waymedia.it/
>
>
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.linux.it/private/imolug/attachments/20100315/f4f0b193/attachment.htm>


Maggiori informazioni sulla lista ImoLUG