[ImoLUG] help [hardware o software??]

daniele daniele_zampighi@tin.it
Sab 12 Feb 2011 13:42:12 CET


ciao ragazzi,
ho un problemone sul portatile dei ragazzi: un Acer Aspire 3100 con 
processore AMD Sempron. installato Ubuntu 10.10

ieri sera  "morto" tra le braccia di mio figlio... e volevo capire dove 
potrebbe essere il problema per rimetterlo in funzione.
[aggiornamento: il problema  nato probabilmente dal cattivo 
funzionamento del cavo di alimentazione, probabilmente connessione 
entrata/uscita con l'adattore, e la pessima condizione della batteria. 
Il tutto ha, probabilmente, generato il problema attuale che vi sto per 
descrivere]

- Se il boot avviene con l'hd si blocca dopo la scelta del kernel (e non 
c' verso neanche in safe mode di procedere), appare un messaggio (spero 
di scrivere bene):

[ 2.153266] CR2: 0000000000f44000
[ 2.154928] --[end trace 78979bbd9183f109 ]---
killed
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have request /sbin/init.
No init found. try passing init= bootarg.

BusyBox v1.15.3 (Ubuntu 1:1.15.3-1ubuntu5) built-in shell (ash)
Enter 'help' for a list of buil-in commands

(initramfs)


come avrete capito ora  aperta una minishell dove qualche comando posso 
darlo, ma nella lista che appare (un po' lunga da copiare a mano) ci 
sono alcuni comandi che conosco ed altri di cui non ne so l'utilizzo e 
magari qualcuno di questi potrebbe auiutarmi a ripristinare il sistema. 
Sapreste darmi qualche indicazione?


Ho provato anche ad inserire un cd live ma:
ubuntu 10.10 non si carica tutto e va in crisi.
knoppix 6.2 si carica ma i comandi sono inacessibili, non funzionanti. 
deduco quindi che non si sia caricato tutto il software
Ho altri cd live (clonezila, linux defender ...) ma non li ho provati...

Ho inserito una chiavetta usb con ubuntu 10.10 per fare il boot ma anche 
dalla chiavetta si blocca come dall'hd e non procede. La cosa 
interessante  che appaiono pi scritte nel log di inizializzazione 
rispetto all'avvio da hd, perch molto pi piccole, ed ecco la cosa che 
colpisce:
nella prima riga del testo visibile c' scritto
[ 5.205689] BUG: unable to handle kernel paging request at 013c1000

a segure alcune righe di log (6 per l'esattezza) e poi alcune che il 
sistema evidenzia di rosso:
[ 5.206440] . . . [8.328241] usb-storage: device scan complete
[ 8.319107] scsi 0:0:0: Direct-Access	FLASH	DISK	0.00 PQ: 0 ANSI: 2
[ 8.330288] sd 0:0:0: Attached scsi generic sg2 type 0 0
[ 8.321216] sd 0:0:0: [sdb] 15794176 512-byte logical blocks: (8.08 
GB/7.53 Gib)
[ 8.335952] sd 0:0:0: [sdb] write protect is off000 EDX: 00000000
[ 8.335958] sd 0:0:0: [sdb] Mode Sense: 00 00 00 00 ESP: f55cd6c
[ 8.336132] sd 0:0:0: [sdb] Assuming Drive cache: wright trhough
[ 8.336132] sd 0:0:0: [sdb] Assuming Drive cache: wright 
trhough.ti=f55c4000)
[ 8.339832] sdb sdb1
[ 8.452839] sd 0:0:0: [sdb] Assuming Drive cache: wright trhough0 
f55c5d94 c058a676
[ 8.452935] sd 0:0:0: [sdb] Attached SCSI removable diskc0 f3344c00 
f3178000 f77df400


a seguire una serie di mount falliti di ext4_comm oppure ext4_msg ecc 
ecc anche un vf_kern_mount
l'ultimo messaggio della schermata 
[ 5.365056] EXT4-fs (sda6): mounted filesystem with ordered data mode


DA CHE PARTE COMINCIO?
:'-(

Avevo pensato di utilizzare una chiavetta con un software molto leggero 
pensando ad un problema della ram ... e spero di non essere molto 
lontano dal problema.
[aggiornamento: ho provato a far partire memtest ma non riesco a finrlo 
perch il computer si spegne, pi o meno verso il 50-60 % dell'intera 
operazione. Quindi direi che sia importante sistemare prima il problema 
cavo/batteria, poi magari affrontare il problema con la ram, se  la 
ram] Attendo comunque le vostre indicazioni per iniziare a metterci le 
mani in modo deciso.

Daniele Z.



Maggiori informazioni sulla lista ImoLUG