[LTP] [PATCH 2/2] tst_test.sh: Add public tst_test_root command

Cyril Hrubis chrubis@suse.cz
Wed Oct 9 14:28:02 CEST 2019

> >> 2. I wanted to make it consistent with other functions, that do similar
> >> stuff like
> >>   ???? tst_test_drivers and tst_test_cmds. Both also call tst_brk in case
> >> of unsuccessful tests.
> > Well I do not like these names either, it's less descriptive that it
> > would have been with tst_require_cmds and tst_require_drivers, so if
> > anything I would be for renaming the tst_test_* ones.
> Fair enough, that makes sense. But then we require a change to 
> tst_test_* first,
> otherwise the api names are inconsistent. And I'm not sure if changing the
> other functions is really worth it.

Should be easy for tst_test_drivers, that one is only used to implement
the NEEDS_DRIVERS variable. And for the second one, we would have to
change a few tests and one line of documentation, but that would be just
a simple script. I can do that if we agree on the change.

@Jan @Peter what do you think?

Cyril Hrubis

More information about the ltp mailing list