[LTP] Rename tst_test_* to tst_require_*

Petr Vorel pvorel@suse.cz
Fri Oct 11 12:06:06 CEST 2019


Cc: Li and Clemens

> these patches rename tst_test_* to tst_require_*, to better describe
> their use. There is also tst_require_root, that has the same
> behavior: It also calls tst_brk in case of a failing requirement.

> You can also get this patch from the following repo:
> https://github.com/MofX/ltp/commits/rename_tst_test-tst_require

sorry for not thinking first, I wonder if we want to sync
tst_test_* (function name) vs $TST_NEEDS_* (test API variable name),
e.g.: tst_require_drivers $TST_NEEDS_DRIVERS

i.e. either of these:

I consider *require* as more descriptive than *needs*,
but changing to *require* would require more work :).

Kind regards,

More information about the ltp mailing list