[LTP] [PATCH V2 2/3] syscalls: sigwaitinfo: Remove SUCCEED_OR_DIE() macro

Cyril Hrubis chrubis@suse.cz
Wed Jul 22 12:09:14 CEST 2020

> The macro makes it less readable and there isn't a great deal of code it
> is trying to remove. Get rid of it.

Looking at the code we may as well add SAFE_SIGEMPTYSET() and
SAFE_SIGADDSET() instead, what do you think?

Cyril Hrubis

More information about the ltp mailing list