[LTP] 回复: [PATCH v2] cleanup: Unify the annotation style and remove Redundant code

Petr Vorel pvorel@suse.cz
Wed Mar 17 12:34:34 CET 2021

Hi all,

> > Hi Gongyi,

> > > Change 'DESCRIPTION' to 'Description' and change 'ALGORITHM' to 
> > > 'Algorithm', and remove Redundant tst_reap_children since 
> > > tst_reap_children has been called in the test skeleton.

> > Reviewed-by: Petr Vorel <pvorel@suse.cz>

> Hi Petr,

> If we want to unify the format of 'Description' and 'Algorithm' in test, it seems redundant to do the conversion in testinfo.pl, right?

> Can we use either of them(not both of them) because it is unnecessary to do the same thing twice.

I'd keep both: this is for cleanup of old approach, conversion in testinfo.pl in
case there is inconsistency in the future.

But not a strong opinion about it, it's not that important.

Kind regards,

More information about the ltp mailing list