[LTP] [PATCH v3 0/7] Refactor mqns testing suite

Richard Palethorpe rpalethorpe@suse.de
Tue Oct 11 12:15:24 CEST 2022


Hello,

Andrea Cervesato via ltp <ltp@lists.linux.it> writes:

> mqns testing suite has been refactored using new LTP API

It would be easier to just submit one test for review and iterate on
it. This follows the principal of breaking work down into the smallest
chunk practically possible.

Sometimes submitting a large patchset is unavoidable, but this is not
the case here.

I'm setting all of these to "changes requested".

>
> Andrea Cervesato (7):
>   Add more safe macros for mqueue API
>   Refactor mqns_01 using new LTP API
>   Refactor mqns_02 using new LTP API
>   Refactor mqns_03 using new LTP API
>   Refactor mqns_04 using new LTP API
>   Delete deprecated mqns header files
>   Rename common.h into mqns.h for mqns suite
>
>  include/tst_safe_posix_ipc.h                  |  45 +++
>  runtest/containers                            |  12 +-
>  testcases/kernel/containers/mqns/Makefile     |  27 +-
>  testcases/kernel/containers/mqns/mqns.h       | 108 ++++++-
>  testcases/kernel/containers/mqns/mqns_01.c    | 185 ++++--------
>  testcases/kernel/containers/mqns/mqns_02.c    | 217 ++++----------
>  testcases/kernel/containers/mqns/mqns_03.c    | 269 +++++++-----------
>  testcases/kernel/containers/mqns/mqns_04.c    | 263 ++++++++---------
>  .../kernel/containers/mqns/mqns_helper.h      |  56 ----
>  9 files changed, 485 insertions(+), 697 deletions(-)
>  delete mode 100644 testcases/kernel/containers/mqns/mqns_helper.h
>
> -- 
> 2.35.3


-- 
Thank you,
Richard.


More information about the ltp mailing list