[LTP] [PATCH v2 1/2] lib: Add helpers for module signature enforcement

Petr Vorel pvorel@suse.cz
Fri Jan 3 10:07:44 CET 2025


Hi Li, Po-Hsu Lin, all,

> Hi Li,

> > > +/**
> > > + * tst_check_module_signature_enforced() - Check if test needs to be
> > > skipped due
> > > + * enforced module signature.
> > > + *
> > > + * Skip test with tst_brk(TCONF) due module signature enforcement if
> > > + * module.sig_enforce=1 kernel parameter or CONFIG_MODULE_SIG_FORCE=y.
> > > + */
> > > +
> > > +static inline void tst_check_module_signature_enforced(void)


> > This function is used to skip tests while detecting the signature
> > enforcement ON, but the name might be ambiguous somewhere.

> +1, I was not sure myself about naming.

> > I would suggest to name it:

> >   tst_check_module_signature_not_enforced(void)  or,
> >   tst_skip_if_module_signature_enforced(void)  or,
> >   tst_requires_module_signature_disabled(void)

> Thanks for the suggestions.  tst_requires_module_signature_disabled(void) looks
> best to me, we use "require" and "needs" for tst_brk().

> I'll wait little longer before merging in case there is some feedback.

FYI patchset merged with rename:
s/tst_check_module_signature_enforced/tst_requires_module_signature_disabled/

Thanks for your review.

Kind regards,
Petr

> Kind regards,
> Petr

> > Otherwise, the whole patch set looks good.

> > Reviewed-by: Li Wang <liwang@redhat.com>


More information about the ltp mailing list