[LTP] [PATCH v2 3/7] Add lsm_get_self_attr02 test
Cyril Hrubis
chrubis@suse.cz
Tue Mar 4 13:29:01 CET 2025
Hi!
> +static void setup(void)
> +{
> + page_size = SAFE_SYSCONF(_SC_PAGESIZE);
> +
> + if (verify_enabled_lsm("selinux"))
> + lsm_count++;
> +
> + if (verify_enabled_lsm("apparmor"))
> + lsm_count++;
> +
> + if (verify_enabled_lsm("smack"))
> + lsm_count++;
This is the same as we have in the common.h (minus the TCONF there)
maybe it would make more sense to split the function in common.h into
two. One that would just return the number of lsm and second that would
also call TCONF if it's zero. That way we could reuse the code here and
keep the number of places with hardcoded security module names smaller.
> +}
> +
> +static struct tst_test test = {
> + .test_all = run,
> + .setup = setup,
> + .min_kver = "6.8",
> +};
>
> --
> 2.43.0
>
>
> --
> Mailing list info: https://lists.linux.it/listinfo/ltp
--
Cyril Hrubis
chrubis@suse.cz
More information about the ltp
mailing list