[LTP] [PATCH] syscalls: rename11: Convert test to new API
Andrea Cervesato
andrea.cervesato@suse.com
Tue Aug 18 13:05:30 CEST 2026
Hi Avinesh,
> +static char elooppathname[sizeof(ELOOPFILE) * 43] = ".";
Magic numbers are a bit unfortunate. It's better to define a single buffer,
which is "big enough", usually PATH_MAX, then append in there the strings we
need.
> +static struct tcase {
> + void (*run)(void);
> + const char *tname;
> +} tcases[] = {
> + {test_eloop, "eloop"},
> + {test_erofs, "erofs"},
> + {test_emlink, "emlink"},
> +};
It's better if we split the test in three, since their are three different
errors reproducers with different input values.
Regards,
--
Andrea Cervesato
SUSE QE Automation Engineer Linux
andrea.cervesato@suse.com
More information about the ltp
mailing list