[LTP] inode: convert to new API and merge into a single test
linuxtestproject.agent@gmail.com
linuxtestproject.agent@gmail.com
Thu Jul 23 13:15:32 CEST 2026
Hi Andrea,
On Thu, 23 Jul 2026, Andrea Cervesato wrote:
> inode: convert to new API and merge into a single test
> + for (i = 0; i < tc->repetitions; i++) {
> + SAFE_READ(1, fd, buf, len);
The literal 1 is used for the len_strict argument here instead of the
symbolic SAFE_READ_ALL. A few lines below, SAFE_READ_ANY and
SAFE_WRITE_ALL are used as named constants elsewhere in the same file,
so this reads as a minor inconsistency rather than a magic number
choice.
Verdict - Needs revision
---
Note:
The agent can sometimes produce false positives although often its
findings are genuine. If you find issues with the review, please
comment this email or ignore the suggestions.
Regards,
LTP AI Reviewer
More information about the ltp
mailing list