[LTP] [PATCH v4] openposix: timers/twoevtimers: Wait for both timer signals

Petr Vorel pvorel@suse.cz
Mon Oct 12 11:33:57 CEST 2026


Hi Jan,

thanks, LGTM.
Reviewed-by: Petr Vorel <pvorel@suse.cz>

> -#define EXPIREDELTA 3
> -#define LONGTIME 5
> +#define EXPIREDELTA_NS 50000000

very nit: having EXPIREDELTA_MS 50 and then use EXPIREDELTA_MS * 1000000
might be slightly more readable.

> +#define LONGTIME 3
> +
> +#define POLL_MS 50
> +#define POLL_COUNT (LONGTIME * 1000 / POLL_MS)

>  #define CHILDPASS 1

> -static int caughtabort = 0;
> -static int caughtalarm = 0;
> +static volatile sig_atomic_t caughtabort = 0;
> +static volatile sig_atomic_t caughtalarm = 0;
nit: static is 0 already (maybe drop "= 0"?)

> -static void handler_abrt(int signo)
> +static void handler_abrt(int signo PTS_ATTRIBUTE_UNUSED)
Thanks for silence some of the warnings.

>  {
> -	printf("Caught abort signal\n");
+1

>  	caughtabort++;
>  }

Kind regards,
Petr


More information about the ltp mailing list