[gl-como] Re: [glux] Upgrade di gnome in Debian unstable

Cristian Rigamonti cri@linux.it
Dom 10 Apr 2005 21:51:01 CEST


On Sun, Apr 10, 2005 at 08:24:39PM +0200, WillY wrote:
> 
> Prova a fare: apt-get install gnome gnome-core gnome-desktop-environment gnome-office

L'avevo fatto; mi dice:

  Alcuni pacchetti non possono essere installati. Questo pu voler
  dire che  stata richiesta una situazione impossibile oppure, se
  si sta usando la distribuzione "unstable", che alcuni pacchetti
  richiesti non sono ancora stati creati o rimossi da incoming.
  Le seguenti informazioni possono aiutare a risolvere la situazione: 

  I seguenti pacchetti hanno dipendenze non soddisfatte:
    gnome-core: Dipende: gnome-applets (>= 2.8.2) ma non sta per essere installato
                Dipende: gnome-panel (>= 2.8.2) ma 2.6.2-2 sta per essere installato
    gnome-desktop-environment: Dipende: gnome-games (>= 1:2.8.2) ma 1:2.6.2-2 sta per essere installato
                               Dipende: gnome-media (>= 2.8.0) ma 2.6.2-0.3 sta per essere installato
  E: Pacchetto non integro

Provando ad aggiornare singolarmente i pacchetti menzionati mi imbatto in altri
blocchi, ad esempio dando
  
  apt-get install gnome-panel gnome-panel-data

ottengo questa dipendenza circolare irrisolta:

  I seguenti pacchetti hanno dipendenze non soddisfatte:
  gnome-panel: Dipende: gnome-panel-data (= 2.8.3-1) ma 2.6.2-2 sta per essere installato
  gnome-panel-data: Dipende: gnome-panel (= 2.6.2-2) ma 2.8.3-1 sta per essere installato

Se chiedo di fare dist-upgrade, mi RIMUOVE comunque: gnome gnome-applets
gnome-applets-data gnome-core gnome-desktop-environment gnome-office e mi tiene
bloccati gnome-games e gnome-panel...

Se chiedo di fare upgrade, NON rimuove nulla, ma ne tiene bloccati molti di piu'
(tra cui quelli che con dist-upgrade rimuoverebbe).

Rimango con le mie due alternative:

- aspetto ancora un po' (perche' c'e' qualche casino temporaneo negli
  archivi debian)

- piallo e reinstallo tutto (perche' ho fatto passare troppo tempo senza fare
  upgrade e i pacchetti sono cambiati cosi' tanto che neanche un dist-upgrade
  risolve la cosa)

Cri

-- 
GPG/PGP Key-Id: 0x943A5F0E         -     http://www.linux.it/~cri/cri.asc
Free software, free society        -     http://www.fsfeurope.org
-------------- parte successiva --------------
Un allegato non testuale  stato rimosso....
Nome:        non disponibile
Tipo:        application/pgp-signature
Dimensione:  189 bytes
Descrizione: Digital signature
Url:         http://lists.linux.it/pipermail/gl-como/attachments/20050410/61c05641/attachment.pgp


Maggiori informazioni sulla lista gl-como