[gl-como] ERRATA CORRIGE: "ERRORE FILE SYSTEM" - Re: Bacula ERROR

Carlo Filippetto carlo.target@tiscali.it
Gio 19 Nov 2009 11:25:11 CET


Visto l'errore del descrittore.. mi sono concentrato sullo starage..
dall'interfaccina grafica non si riscontrano problemi, accedendo alla
directory montata idem, ma accedendo direttamente in ssh allo storage (l'ho
dovuto 'craccare' per abilitarla) qualcosa di strano  apparso:

ecco cosa succede dal mio server:
# ls VOL-weekly-*
VOL-weekly-0001  VOL-weekly-0002  VOL-weekly-0003  VOL-weekly-0004
VOL-weekly-0006

ecco cosa succede con medesimo comando dallo storage:
# ls VOL-weekly-*
ls: VOL-weekly-0007: Invalid argument
ls: VOL-weekly-0008: Invalid argument
ls: VOL-weekly-0009: Invalid argument
ls: VOL-weekly-0010: Invalid argument
ls: VOL-weekly-0011: Invalid argument
ls: VOL-weekly-0012: Invalid argument
VOL-weekly-0001  VOL-weekly-0002  VOL-weekly-0003  VOL-weekly-0004
VOL-weekly-0006


col 'tab' me li vede, ed ovviamente se provo a rimuoverli otengo:
# rm VOL-weekly-0007
rm: unable to stat `VOL-weekly-0007': Invalid argument



Quindi la domanda non  pi inerente a Bacula, ma al file system.. come
cancello adesso quelle cose??
Il file system  un xfs

CIAO




Il giorno 19 novembre 2009 10.56, Carlo Filippetto
<carlo.target@tiscali.it>ha scritto:

> Ciao a tutti,
> ho un problema con Bacula che non riesco a risolvere..
>
> Tutti i backup vengono eseguiti su disco,  ho diversi tipi di backup,  fra
> cui: giornaliero, bi-settimanale e mensile. Tutti insistono sul medesimo
> storage esterno (chiamarlo storage  un eufemismo  una baracco della Lacie
> con 4 dischi in Raid 10) ed i dati finiscono sulla medesima directory, altre
> dir le differenzio solo per altri tipi di backup
>
> Il servizio  funzionante da ormai 5 mesi e tutto funzionava fino a 3
> settimane fa quando mi si  bloccato su un backup settimanale (numerato come
> VOL-week.007) dicendo che non trovava un disco, strano.. sono tutti li..
> nessuno li ha toccati.. e questo 'errore' mi ha tenuto fermo i backup per 3
> giorni senza mandare alcun allarme. A parte non capendo cosa succedeva dopo
> vari smanettamenti, cancellazioni di job, test, ecc.. La cosa bella  che se
> manualmente accedevo al disco e toccavo qualsiasi cosa, mi si inchiodava lo
> storage.
> Alla fine ho rimosso sia dal disco che dalla consolle tutti backup vecchi
> relativi a quel gruppo. Distrutto il Pool e ricreato. Bacula ha ripreso a
> funzionare correttamente.. ag oggi mi ritrovo nuovamente col medesimo
> problema ed il medesimo errore.. cio blooco sul VOL-week-007 e chiede di
> montare il disco.
> Attivato i debug ottengo:
>
>
> -------------------
> *bacula-sd: mount.c:643-0 Create volume label
> bacula-sd: label.c:325-0 write_volume_label()
> bacula-sd: label.c:346-0 New VolName=VOL-weekly-0007
> bacula-sd: dev.c:303-0 open dev: type=1 dev_name="DEV-nas"
> (/mnt/backup/backup) vol=VOL-weekly-0007 mode=OPEN_READ_WRITE
> bacula-sd: dev.c:312-0 call open_file_device
> mode=OPEN_READ_WRITE
> bacula-sd: dev.c:2018-0 Enter
> mount
>
> bacula-sd: dev.c:484-0 open disk: mode=OPEN_READ_WRITE
> open(/mnt/backup/backup/VOL-weekly-0007, 0x2, 0640)
> bacula-sd: dev.c:491-0 open failed: dev.c:490 Could not open:
> /mnt/backup/backup/VOL-weekly-0007, ERR=Descrittore di file non valido
> bacula-sd: dev.c:499-0 open dev: disk fd=-1 opened, part=0/0,
> part_size=0
> bacula-sd: dev.c:316-0 preserve=0x0
> fd=-1
>
> bacula-sd: dev.c:303-0 open dev: type=1 dev_name="DEV-nas"
> (/mnt/backup/backup) vol=VOL-weekly-0007 mode=CREATE_READ_WRITE
> bacula-sd: dev.c:312-0 call open_file_device
> mode=CREATE_READ_WRITE
>
> bacula-sd: dev.c:2018-0 Enter
> mount
>
> bacula-sd: dev.c:484-0 open disk: mode=CREATE_READ_WRITE
> open(/mnt/backup/backup/VOL-weekly-0007, 0x42, 0640)
> bacula-sd: dev.c:491-0 open failed: dev.c:490 Could not open:
> /mnt/backup/backup/VOL-weekly-0007, ERR=Descrittore di file non valido
> bacula-sd: dev.c:499-0 open dev: disk fd=-1 opened, part=0/0,
> part_size=0
> bacula-sd: dev.c:316-0 preserve=0x0
> fd=-1
>
> bacula-sd: reserve.c:534-0 jid=1124 vol_unused: no vol on "DEV-nas"
> (/mnt/backup/backup)
> bacula-sd: dev.c:1848-0 Clear volhdr
> vol=
>
> bacula-sd: mount.c:648-0 write_vol_label failed. vol=VOL-weekly-0007,
> pool=POOL-weekly
> bacula-sd: mount.c:217-0
> set_unload
>
> bacula-sd: mount.c:220-0 goto
> mount_next_vol
>
> bacula-sd: mount.c:88-0 mount_next_vol
> retry=5
>
> bacula-sd: jcr.c:603-0 OnEntry JobStatus=R
> set=M
>
> bacula-sd: jcr.c:623-0 OnExit JobStatus=M
> set=M
>
> [Thread 0xb69b9b90 (LWP 10903) exited]      *
> ----------------------------------------------
>
> qui si ferma tutto
>
>
> Qualche consiglio? idee?
>
> Grazie
>
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.linux.it/pipermail/gl-como/attachments/20091119/351de30e/attachment-0001.htm>


Maggiori informazioni sulla lista gl-como