Jornada820 Digest, Vol 4, Issue 25

G Almasi
Tue Feb 24 02:27:53 CET 2004

>   Some things are really generic and not jornada820
>   specific (like pcmcia/sa1100_jornada820.c).
>   It asks for pcmcia/sa1101_generic.c name (and is a port
>   of sa1111_generic.c anyway).

Not true, unfortunately. The way power is set for the cards is
implementation dependent. I believe that I haven't yet gotten
it right for the Jornada either. In any case, most of the code
could migrate to sa1101_generic, but there would still be a
need for sa1101_jornada820.c file.

In time, I will do it. I believe that right now we have more
urgent things to do.

> From: David Jones <>
> FYI.  I'm trying a newer version of busybox with some
> optional items turned on.  If this does what I think
> it will, it will allow transfer of the boot/init
> process to the CF card and remove the ramdisk.  I got
> it to cross-compile last night but ran out of time to
> try it.  We'll see what happens tonight:)

I thought busybox 1.00-pre7 *was* the latest version!
In any case, if you want to change the release there's
a single place in ramdisk/buxybox/Makefile to do it.

> P.S.  Has anyone tried to get the touch pad working?

It's working in yesterday's release (tagged FEB22_2004).
Try it with gpm.

> Actually, you know, after having learnt the hard way about 0xC005C080,
> I took it as a honor and a priviledge that you would let me
> put in the kernel the lines that program around this "interesting
> feature".

Oh boy ;-)

> We *know* from Documentation/initrd.txt that we can get rid of it
> later;
> it's just a SMOP. So I vote for a maximal busybox in our default
> ramdisk.

OK. I will start turning on features I think we might need.
Don't let that stop you from turning on even more. CVS is very good
about fixing when we step on each other's toes.

> Beware: pivot_root mightn't like programs already started
> on other virtual terminals. More accurately, after the pivot_root,
> you must umount the initrd, and then flush the ramdisk;
> but you can't umount the initrd if processes still use it
> (even if it's only having their cwd pointing to it).

You are right. The /etc/init.d/rcS script should behave intelligently
and not start those programs if we are preparing to pivot_root. rcS
can *attempt* to mount root from /dev/hda2; if it fails, we know that
the ramdisk stays.

> Oh, so you tried it. Ahem.
> Maybe we can trim the default emacs configuration
> so that it will start faster?

Actually ... if I turn on my memory extension (so I have 32 MB of RAM)
emacs comes up in only 5 seconds ;-)

> Actually, you had command line history with C-p and C-n,
> just like in Emacs :)

I noticed. But typing ctrl-n makes me remember my carpal tunnels.

> OK, so can anyone more knowledgeable than I (or willing to become so)
> fix the lack of cursor? I suppose there's something to do in
> sa1100fb.c.

Oleg noted this also. This may be a busybox problem. The cursor always
shows up in emacs, but never in the terminals. Weird.


More information about the Jornada820 mailing list