Bugs, bugs, bugs.

Oleg Gusev oleg@usm.uni-muenchen.de
Wed Mar 3 19:54:55 CET 2004

I have managed to unmount the ramdisk, and now
everything works as expected. I have also created
/dev/touchscreen/ucb1x00 and linked /dev/ts to it.
Let the X server be happy. Now to the problems.

1. We don't have unified CF rootfs. I have taken
initrd.tar.gz from Zaurus C760 and put a lot of
debian packages on the top of it, but will prefer that
everybody has an equal setup.

2. The pcmcia start script does something very stupid.
I have removed it from the automatic startup and
start 'cardmgr' manually. This is the log:

Starting PCMCIA services:/sbin/ifconfig eth0 down
sa1100_pcmcia_suspend(): suspending socket 0
sa1100_pcmcia_suspend(): suspending socket 1
hda: status error: status=0x00 { }
hda: drive not ready for command

WHY would one want to suspend the disk where you are
running from ???
The output of 'cardctl' is also very funny:

Socket 0:
  3.3V 16-bit PC Card
  function 0: [ready]
Socket 1:
  3.3V 16-bit PC Card
  function 0: [ready], [bat dead], [bat low]
                                  ^^^^^^^^^^^^^^^^^^ ???

3. The portmap and sshd are started, but immediately disappear without 
leaving any traces. 
If i start them manually, i get the same result. 'sshd -d' works,
ssh/scp _from_ the j820 also work. 'mount -o nolock -t nfs' works.

4. I get OOPS trying to read from the first 8 pages in /dev/mem ! Why ?
   Then there is this stupid counter...

5. The sound is not working, but it is some minor problem with enabling
    MCP transfer. I have added the code to show ADC0 status and IO pins
    in /proc/j820. This data goes through the same route as audio.

6. It is possible to do 'loadkeys de' with a surprisingly good result, but
    many keys need special mapping.

7. X server doesn't really like 'gpm'. Sometimes it works, sometimes hangs.

8. I run 'getty' on /dev/ttySA0 (and run with the serial console ) and 
   somehow it doesn't get the SIGHUP on disconnect. Maybe this is a getty
   bug, but i have some concern about the RTS/CTS setup. Is it really
   hardwired, or does it need some software help ? Another interesting
   test will be to use 230400 kbit on ttySA0, but my AMD768 has problems
   already at 115200 and sometimes locks up to whole machine.

9. IRDA is still untested. If somebody can do something useful with it
    i'd like to hear from him.

10. If you start X from the serial console when the framebuffer went to 
      powersave, not always you get what you want.

11. The 'disappearing cursor' problem remains. As i have already written,
      you can start 'top' and then kill it with 'k pid 9'. Then it keeps its
      enabled state.

12. Powersave is another thing to be addressed...


More information about the Jornada820 mailing list