Kernel 2.6.11

Matan Ziv-Av
Tue Mar 8 14:06:05 CET 2005


I tried getting kernel 2.6.11 to work on the J820.
After making the minimal changes:

arch/arm/boot/j820 directory
And the various changes to Makefiles and Kconfigs.

The kernel builds, but on boot, the last message is

Memory policy: ECC disabled, Data cache writeback

(from the file arch/arm/mm/mm-armv.c). After adding a few debug printks, 
it appears as if the problem is in the flush_tlb_all() at the end of the 
function memtable_init in that file.

I tried both linus 2.6.11 and 2.6.11-hh0, with the same results. When I 
tried doing the same with 2.6.7, there was no problem, and the 
2.6.7 kernel I compiled does boot OK. I can't find any significant 
change in the low level init, or the mmu handling between 2.6.7 and 

I intend to try to debug this in the near future, but if someone has any 
idea about what might be the problem, I'll be glad for any advice.

Matan Ziv-Av.               

More information about the Jornada820 mailing list