[openvideo-it] R: Re: provare la struttura di un DVD video prima di bruciare il supporto

emaggiani@alice.it emaggiani@alice.it
Mer 18 Mar 2015 18:05:43 CET


Ho provato il metodo che mi hai suggerito: ho ricompilato la libreria dal sorgente, ma senza alcun risultato, sia con mplayer che con vlc, ottengo lo stesso messaggio di errore!

Ma non credo comunque che il problema stia della libreria css - dato che non sto parlando di DVD commerciali, ma di DVD autoprodotti con dvdauthor.

Devo fare altre prove con un DVD commerciale, copiando su disco la struttura con vobcopy, ma il problema  forse proprio dvdauthor <http://sourceforge.net/p/dvdauthor/mailman/message/28769379/>

ciao


----Messaggio originale----

Da: giorgio.arlanch@gmail.com

Data: 17-mar-2015 17.50

A: <openvideo@lists.linux.it>

Ogg: Re: [openvideo-it] provare la struttura di un DVD video prima di bruciare il supporto



CIao, io uso debian e non ho problemi con vlc per vedere dvd.
La libreria libdvd la compilo per con questi semplici passaggi:

scarico ultima versione da:
http://download.videolan.org/pub/libdvdcss/

e poi compilare nella cartella decompressa:
./configure --prefix=/usr
make
sudo make install

prova e fammi sapere

Giorgio


Il giorno 16 marzo 2015 19:36, emaggiani@alice.it <emaggiani@alice.it> ha scritto:
Sono recentemente passato da Fedora a Ubuntu, che sto ancora configurando per il multimedia ;-)

In particolare ero abituato a provare la struttura e i menu di un DVD prima di bruciare i supporti, con il comando:

mplayer dvd://  -dvd-device DVD_fs

dove DVD_fs  la cartella che contiene la struttura suddetta creata da dvdauthor.

Con Fedora tutto andava liscio, dopo aver configurato opportunamente tutto il multimedia (cosa anche l non dappoco).

Ma ora con KXStudio (sostanzialmente: Ubuntu 14.04 LTS)

mplayer esce con questo errore:

MPlayer 1.1-4.8 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://.
libdvdread: Couldn't find device name.
There are 6 titles on this DVD.
There are 1 angles in this DVD title.

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1264 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn < 100 ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1264 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn < 100 ***

libdvdread: Invalid IFO for title 1 (VTS_01_0.BU).

Cannot open the IFO file for DVD title 1.
No stream found to handle url dvd://


Exiting... (End of file)

Ho provato allora con vlc, seguendo i consigli di <http://g-raffa.eu/Cinelerra/HOWTO/DVD.html#_using_the_command_line_xine>
ma ottengo lo stesso:

VLC media player 2.1.2 Rincewind (revision 2.1.2-0-ga4c4876)
[0x1a36118] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
[0x1c4e2f8] main playlist: stopping playback
[0x7f3e70003438] idummy demux: command `nop'
[0x1c4e2f8] main playlist: stopping playback
libdvdnav: Using dvdnav version 4.2.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: Unable to find map file '/home/em/.dvdnav/.map'
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1264 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn < 100 ***

libdvdnav: ifoRead_VTS_PTT_SRPT failed
vlc: vm.c:1545: process_command: asserzione "0" non riuscita.
Annullato

Ho naturalmente installato la libreria lbdvdcss seguendo la procedura indicata in <https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs>  e l'utility regionset anche se non credo che il problema stia l.
Sembrerebbe piuttosto che la libreria libdvdread non trovi il dispositivo, anche se per lo meno mplayer vede che ci sono (e giustamente) "6 titoli" (o  solo un caso?) nel men.

Ora in questa macchina ci sono due dispositivi ottici:
ls -l /dev/sr*
brw-rw----+ 1 root cdrom 11, 0 mar 16 16:52 /dev/sr0
brw-rw----+ 1 root cdrom 11, 1 mar 16 16:52 /dev/sr1

uno dei quali collegato a /dev/cdrom
ls -l /dev/cdr*
lrwxrwxrwx 1 root root 3 mar 16 16:52 /dev/cdrom -> sr0

Ho provato allora a creare un altro link simbolico con:
sudo ln -s /dev/cdrom /dev/dvd

ma il risultato non cambia

Qualcuno ha qualche idea in proposito?

Grazie
enrico



--

Mailing list info: http://lists.linux.it/listinfo/openvideo








-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.linux.it/pipermail/openvideo/attachments/20150318/f216bb4b/attachment.html>


Maggiori informazioni sulla lista Openvideo